'02 Yukon bumps on turns

We have a 2002 Yukon with 38k on the odometer, just out of warranty. When it is turned either way there is a bump in the rear suspension. It is on the driver's side and somewhere near the axle. It is loud enough to hear
over the radio but not much louder than that. I have been on the creeper twice and can't find anything loose to my shaking and beating.
Any ideas?
Thanks, Karl
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Had a problem on my Blazer -- the problem was very rare at first, then louder as time went on to the point that it was almost all the time. It turned out that it was my Torsion Bar Crossmember Mounts had rotted out and the crossmemeber was hitting down on the frame.
I would check all your bump stops and mounts for wear -- or for seperation of the rubber from the metal.
-Joe

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
<Take it to the dealer and have them relube the steering shaft. There is a service bulletin on this issue, the column was not packed with enough grease on the assembly line. They fixed this exact issue on my 2002 Suburban
The same thing was done to my 2002 Silverado.
JP
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.