1989 k-1500 acceleration problem

I have a 1989 chevrolet k 1500 4x4 truck with the 4.3 L TBI Engine. When accelerating, the truck seems to stumble/hesitate. It almost feels like the truck is bucking up the road. It will do this if you
hit the gas hard, but stops when you let off. Put new plug wires on about 2 months ago. any idea what the problem could be??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 29 Apr 2008 19:59:51 -0700 (PDT), thirdeye

Could be a lot of things, but I think I'd try and change the fuel filter first. -- Old Crow '82 FLTC(P) '95 Wrangler YJ BS#132, TOMKAT, SENS, SLOB#13
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

...and spark plugs, and perhaps a new distributor cap and rotor, is where Id go next.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
message

Just had a similar problem with a 94 K1500 5.7. Idled OK, cruised OK, accelerated OK if I was very gentle. Any normal acceleration bucked/stumbled badly.
It's probably ignition. Plugs, wires, distributor cap, rotor. Mine was distributor cap. The center tower contact was melted and loose and the coil wire was fried.
DO NOT use a cap/rotor with aluminum connectors. Spend the money for brass!
Bill
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

com...
having same problem w/94 K1500 replaced plugs, wires, fuel filter, distributer cap & coil wire. When I first start up and 1st mile or so no problem, then starts stumbling unless real slow with accelerator. Going to replace coil while I wait for a reply. kirk
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@hotmail.com wrote:

message
My 1984 GMC Jimmy High Sierra stumbles while accelerating from about 40 to 45 when in overdrive, but does okay when in regular drive.
Terry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On May 17, 7:20pm, snipped-for-privacy@hotmail.com wrote:

s.com...
Replaced coil, idle speed control, ignition contol module. Still stumbling on accelleration from idle any ideas??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Mon, 2 Jun 2008 09:32:03 -0700 (PDT), snipped-for-privacy@hotmail.com wrote:

message
Check out the EGR. If it opens too wide or too soon it'll cause a stumble off idle. -- Old Crow '82 FLTC(P)'Pearl' '87 FLTC '?' '95 Wrangler YJ BS#132, TOMKAT, SENS, SLOB#13
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.