1989 s10 700r4 problem

I have a 1989 chevy s10 (4.3L) with a 700r4 transmission [all stock] and i was going down the interstate at about 75mph and approached an incline.. held steady on the throttle and the transmission (even with a recent
filter/fluid change; perfect fluid level) shifted down 1 gear too many or something but just for a spliit second... then went into the proper gear.. acted fine for the rest of the highway.... then i get to the end of the offramp... come to a dead stop and when the light turns green I give it gas and it bangs (like bang bang bang) into 1st gear... then when it shifts into second it shifts HARD... So hard it shutters and shakes the truck...???? seems fine in the gears after that.... Problem has been ever since...
A close look reveals: 1.) It has no problem with reverse 2.) It will grab 1st fine when manually put into 1st (or 2nd) AND... 3.) Has no problem with the 1-2 shift when manually put into 2nd (What I put it in to start off with now) 4.) Only has the problem in drive and overdrive 5.) Can still do a mean brake stand!
Any help would be appreciated. I'm mostly wondering if there is a quick fix (Like something to replace with the tranny in the vehicle) or If I really have to switch it out with my space 700r4 from the same type of truck Thank You! ---> jurtaman!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Quick fix:
take it to the local tranny shop and have them rebuild it.
I had a very similar problem and my tranny turne dout to be basically roasted. Of course, I'd just completed a 2 hour trip with it before I noticed the problem.

1st
put
fix
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.