1990 CHEVY 1500 4X4 DOESNT ENGAGE PLEASE HELP

When I put the transfer case shifter into 4 wheel drive (either 4hi or 4lo) nothing happens. The transfercase seems fine, it goes into each gear fairly
easily sometimes a mild grind? but you can feel it engage into gear. the 4x4 light on the SHIFTER doesnt go on. 2wd light works fine. I checked fuses, and damaged wire. Driveshafts lock and turns when in drive, but front wheels dont lock. I replaced what I was told was a bad acctuator, and nothing. there are no vaccum lines anywhere on transfer case, or front diff. just breathing hoses, otherwise it's all electrical. Can I convert to manual locking hub. There is no switch to engage 4x4 just shifter. IM LOST any suggestions please.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 31 Dec 2003 07:00:03 -0600, "1990chevy4x4"
nothing happens. The transfercase seems fine, it goes into each gear fairly easily sometimes a mild grind? but you can feel it engage into gear. the 4x4 light on the SHIFTER doesnt go on. 2wd light works fine. I checked fuses, and damaged wire. Driveshafts lock and turns when in drive, but front wheels dont lock. I replaced what I was told was a bad acctuator, and nothing. there are no vaccum lines anywhere on transfer case, or front diff. just breathing hoses, otherwise it's all electrical. Can I convert to manual locking hub. There is no switch to engage 4x4 just shifter. IM LOST

put the truck up on stands, turn the ignition on, shift it into 4wd, unplug the actuator and look for 12V.
if you have 12V:
pull the actuator, plug it into the harness and see if it pushes it's plunger out.... if no, actuator is bad; if yes take a 1 ft long wooden dowel and push the plunger inside the diff in, if it engages smoothly or requires a slight rotation of the tires to engage your axle is ok, if it won't engage, or the plunger is stuck in, you're bound for some expensive repairs to the front axle..(I've been told the word nightmare comes to mind).
if you didn't get 12V:
double check the key is on, reach up on top of the xfer case and unplug the connector, probe the brown wire (should be the center one). if you have 12v, replace the switch on the xfer case, if no 12V keep looking up the line.
HTH, Bret
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 31 Dec 2003 07:00:03 -0600, "1990chevy4x4"
nothing happens. The transfercase seems fine, it goes into each gear fairly easily sometimes a mild grind? but you can feel it engage into gear. the 4x4 light on the SHIFTER doesnt go on. 2wd light works fine. I checked fuses, and damaged wire. Driveshafts lock and turns when in drive, but front wheels dont lock. I replaced what I was told was a bad acctuator, and nothing. there are no vaccum lines anywhere on transfer case, or front diff. just breathing hoses, otherwise it's all electrical. Can I convert to manual locking hub. There is no switch to engage 4x4 just shifter. IM LOST

I don't know if its the same problem, but a similar thing happened to me on a 92 siverado 4x4. I had to have the 4x yoke changed out to a different replacement part as the original part was known defective. Of course Chevy didn't pick up any of the cost, even though they sold a defective product. In their defense, it did last 7 years before it failed. I don't remember what it cost, but it wasn't cheap. Over $400.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Using a doll rod doesnt seem to logical if the actuator works does it?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.