1990 GMC Suburban

HI All Thanks in advance 1990 GMC Suburban Vehicle has been running smooth no problems except it needs new exhaust from muffler out. I'm wondering if this has to do with my
current problem. Started the vehicle yesterday and it ran rough, started down the road and it felt like it wasn't running on all cylinders. Very noticeable expecially when first starting out. I turned around and parked it after a 1/4 mile. Where should I start? Thankyou Ross
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

With the little bit of info you've posted I would say that you need to first get the computer checked for error codes. Could be anything causing your problem. The exhaust I doubt has anything to do with it.
Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the dist. cap for moisture and wear.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
1990 GMC Suburban

Had a similar problem on my 1990 and couldn't locate it until it threw me a "lean" code.
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% There are two classes of pedestrians in these days of reckless motor traffic - the quick and the dead. ~ Lord Dewar 1933 ~
Climbing into a hot car is like buckling on a pistol. It is the great equalizer. ~ Henry G. Felsen 1964 ~
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had one exhibit these symptoms. Bad plug wire. Carroll Senn Columbia, SC (remove NOSPAM to reply)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.