1995 K2500 idle

We have a 1995 Chevy K2500 that my daughter has been driving. Yesterday it began have an idle problem. It started fine and idled OK, but when she put it into gear, it idled roughly and died. I looked at
it today and sometimes it idles OK in P or N, but sometimes it's rough. Putting it in gear makes it idle rough.
My daughter said she didn't have any warning of a problem until yesterday, but it's possible that she didn't notice. I drove it a week or two ago and it was fine.
I check and got no error codes.
It's been cold (-20), but we've been around +20 the last few days.
Any ideas of where I should look first?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I'd suspect a loose vacuum line or the EGR valve stuck partially open.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The spark plug gaps were up to about 0.05" (rec 0.35") and the center pin in the dist cap was broken. I replaced them (but not the wires), but still have the problem. I've since replaced the EGR valve and searched for a loose/broken vacuum line. Still no luck.
I was out in it the other yesterday and noticed that periodically the truck would vibrate at a low frequency. It was almost like a shake, not a vibration.It would happen for a few seconds one or twice a minute.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.