1995 S-1o Fuel Injector/ Running Rough

I just replaced a fuel injector in a 2.2l s10 . Now , I have a miss at low speeds .
and Idle . Anyone experience this. Maybe anything , vaccum. sparkplug miss , egr ?
Any thoughts?
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Look really closely when it's running, and see if it's pissing fuel around the body of the injector - you might have missed a seal/washer that goes around the injector body, and now it's pouring in the gas.
Do it soon too, or you'll overload and fry your cat.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Why did you replace the injector? Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bob wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

That's what I'm thinking, if it was running like a clock before why'd he replace the injector? Probably just misdiagnosed the original problem. Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"puttputt" wrote > I just replaced a fuel injector in a 2.2l s10 . > Now , I have a miss at low speeds . > > and Idle . > > Anyone experience this. > Maybe anything , vaccum. sparkplug miss , egr ? > > Any thoughts
I replaced the injector , because it was leaking .
Come to find out NAPA sold me a bad injector.
The Stumbling problem is still there. On exceleration.
When pressing the gas , the truck stumbles .
Still no resolution for this problem.
I did have it diagnoissed , nothing came up .
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.