1997 Chevy K2500 way too rich

OK I started with a tune-up (plugs,wires,cap&rotor,and fuel filter) Started running Way too rich backfires through the exhaust and gets really bad mileage(duh). I don't have access to a OBD2 machine and there is also
no check engine light on! Where do I go from here?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
OK I started with a tune-up (plugs,wires,cap&rotor,and fuel filter) Started running Way too rich backfires through the exhaust and gets really bad mileage(duh). I don't have access to a OBD2 machine and there is also no check engine light on! Where do I go from here?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
tbillsfan wrote:

Does it run fine cold and then load up when it warms up?
--

-----------------
www.thesnoman.com
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Might be that the wires are crossed..I did that one time!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check your firing order. Make sure all the plugwires on both ends are nice and snug.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.