1997 S-10 occasional no start

i have a 97 s-10 4cyl 5 speed that sometimes will not start. press the clutch, turn the key all the dash lights come on and i can hear the fuel pump engage, but nothing happens (not even a click). it is like you
haven't pressed the clutch at all. i have had the nuetral safety switch and the starter replaced at different times to try to correct this problem. even had it towed to the garage because it wouldn't start in the driveway. when the mechanic got it to the shop, it cranked right up. also will start if you push the truck and pop the clutch. this has been going on for 2 years or better. does anyone have any ideas??? thanks for your input.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
rustyshackelford wrote:

Ignition switch or wiring to the switch?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I too have the no start condition and hope I solved mine with a new starter. So damm intermitt that I am not certain if starter fixed the problem. The start relay under the hood costs about 40 bucks from dealer.
there seems to be a long path to the starter that goes something like this on the automatic transmission version, but I suspect the manual has similar
Key to neutral/park shift sensor to start relay under hood to finally the starter solenoid and then the starter windings. Any place along the line can mess things up. If you can probe at the relay under the hood, this would be a good half way point to determine which direction to go.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
thanks guys, i hope to get this resolved today. or atleast eliminate a possibility or two. i'll let you know how it goes.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
o.k. it's been a while but i finally got this issue resolved. remove the nuetral saftey switch and use a jumper wire to bypass the switch. worked like a charm. thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

So, your starter will now engage when the transmission is in gear?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
rustyshackelford wrote:

    Try adjusting the switch. If you can't, replace it. Charles
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.