1998 Blazer Fuel Gauge Problem

Hi all, I have a 1998 Blazer with about 108,000 miles on it. When I fill the gas tank it will record a full tank like it should. When I get down to about
1/4 of a tank, the fuel gauge will start to go crazy. It will bounce from empty to full and the less gas in the tank the closer the gauge will get to register full. When I do fill the tank again, it will register fine until I get back to 1/4 of a tank or lower. Anybody every have this type of problem before? Any idea what to look for here? Thanks for reading my post. Big Duke
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a 1996 Blazer that had the same symptons, it was a bad sending unit. I also got error codes for it. Don't remember what number it was. Chuck

to
until
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Big Duke wrote:

Sending unit is starting to go bad. Basically I would live with it until the fuel pump goes since it is part of the fuel pump module. Or you could replace the pump module before it fails. But it isn't real cheap. 200 bucks or so for the part.
--
Steve W.
Near Cooperstown, New York
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Dealer charged me $1200 to have it done last year after the pump failed at 80K :-(
wrenden
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrenden wrote:

Ouch! I would look at the dealer invoice and see if it is covered under the defective parts warranty. If it has been a year it should be.
--
Steve W.
Near Cooperstown, New York
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks for all the information guys. I guess I can live with it. What I've been doing is just estimating the gas mileage at about 20 MPG to figure out when to get fuel. So far it's working out OK Duke
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.