1998 Jimmy Engine DIes

Any advice is appreciated.
I have a 98 Jimmy SLE A/T. Driving at 30 - 35 mph it will be running perfectly and then the engine will start coughing like a miss or lack of
fuel.
Sometimes the engine will die. It starts immediately with the key.
This also happened about 15,000 miles ago but at higher speeds like 60 - 70 mph.
It does not set any codes for the mechanic to check.
At that time I changes plugs, plug wires, distributor cap and rotor. Also changed fuel and air filters.
Problem seemed to go away. Now it's back again.
When the problem is NOT happening the engine and trans run perfectly. ANY IDEAS??
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Corroded battery cables or loose block ground.
Doc

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Distributor pickup,
Or if DIS equipped, Crank Position Sensor might be a good place to look at.
I hope this helps?
Refinish King

Also
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My wifes 1998 jimmy was doing something similar. Turned out that the in-tank fuel sending unit/pump was shutting down intermittently. I didn't realize this until I listened to the pump running while the car was in park/idling and the pump just shut off. A few seconds later, the engine died. After sitting a few minutes, it would start right back up. After replacing the unit bought on Ebay Motors (AC Delco part number MU85) for $150, no problems since. Hope this helps. Andy

70
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.