1998 S10 Blazer starting up problem

A few days ago I was having trouble starting up my blazer. It would take 2 tries to start my car. I replaced the battery because it was old already. Now with a new Interstate battery I still got have
trouble starting my car at times. This does not happen all the time but I would say 2 times out of 10 it will happen. Any ideas. How reliable is this blazer going to be in the future. It has 78,000 miles on it. Is it time to let this car go?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
what trouble are you having? cranks fine but no start? slow crank no start? slow crank then start? no crank? we need details man!
-Bret

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Usually I can crank once really quick and start the car. Now If I crank it fast at times, it will not start. It will start fine if I crank it to the first position to let the electricity run through for 2 seconds, then it starts up fine. I am not an expert so therefore I could not provide the information in my first post. Thanks for the responses

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I've got a 97 Blazer with the same problem. 82000mi. It's slowly been getting worse, and now my service eng soon light is on most of the time. I replaced the cap , rotor, wires, plugs, and fuel filter. The fuel pressure is good with engine running and on initial start (55-60psi). The pressure drops after the fuel pump cuts out during the start, like there is a check valve leaking some where. I usually have to give it a little gas to get it going. My idle is a bit rough as well. I had been told to check the screen on the fuel pump as this has been known to cause these problems on the 4.3 Vortec. That involves dropping the tank and I was hopping to avoid it, but it is about all I have left to check. Any thoughts?
Jim

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Jim you need a fuel pressure regulator which regulates the pressure in your fuel rail even though your pump gives out if it builds pressure it shouldnt drop...What codes are your pcm shooting out ?If I had them i could help you better.......
Dave, Could be alot of things like Starter.ignition switch need more info when it doesnt want to start does your starter drag or is there no starter but you hear the the sil clicking...Need more info
Re: 1998 S10 Blazer starting up problem Group: alt.autos.4x4.chevy-trucks Date: Wed, Oct 8, 2003, 4:38pm (CDT+1) From: snipped-for-privacy@home.com (jk) I've got a 97 Blazer with the same problem. 82000mi. It's slowly been getting worse, and now my service eng soon light is on most of the time. I replaced the cap , rotor, wires, plugs, and fuel filter. The fuel pressure is good with engine running and on initial start (55-60psi). The pressure drops after the fuel pump cuts out during the start, like there is a check valve leaking some where. I usually have to give it a little gas to get it going. My idle is a bit rough as well. I had been told to check the screen on the fuel pump as this has been known to cause these problems on the 4.3 Vortec. That involves dropping the tank and I was hopping to avoid it, but it is about all I have left to check. Any thoughts? Jim
A few days ago I was having trouble starting up my blazer. It would take 2 tries to start my car. I replaced the battery because it was old already. Now with a new Interstate battery I still got have trouble starting my car at times. This does not happen all the time but I would say 2 times out of 10 it will happen. Any ideas. How reliable is this blazer going to be in the future. It has 78,000 miles on it. Is it time to let this car go?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the input. I don't have a code reader, I've been balking at the price. Can you recommend a reasonably priced reader?
Jim
A few days ago I was having trouble starting up my blazer. It would take 2 tries to start my car. I replaced the battery because it was old already. Now with a new Interstate battery I still got have trouble starting my car at times. This does not happen all the time but I would say 2 times out of 10 it will happen. Any ideas. How reliable is this blazer going to be in the future. It has 78,000 miles on it. Is it time to let this car go?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.