2000 GMC Jimmy keeps running (sometimes -- intermittent)

About once in every five times i drive my 2000 GMC Jimmy, it keeps running after I turn the key to the off position. The dashboard goes out (all of the gauges stop working, too) but the engine keeps right
on running. The first time this happened I pulled the fuse to the ECM and it stopped right away.
Here's the really odd part: out of desperation, I tried every button in the cab the next time it happened. Lo and behold, turning the hazard light on and off kills the engine. I also noticed that sometimes I'll have my foot on the brake when I turn the engine off, and the engine will keep running until I take my foot off the brake.
This may be related, I don't know: the right turn signal comes on an stays on (doesn't blink). I tried replacing the blinker module behind the glove compartment, but that didn't change anything. Left turn signal works, and occasionally blinks fast like there's a bulb out, then goes back to normal after a while. All the bulbs are fine.
Any thoughts?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote:

Bad multifunction switch in the column.
--
Steve W.
Near Cooperstown, New York
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.