2001 Suburban SERVICE 4WD light...

Hello All,
I just bought a used 2001 Suburban with 40K miles on it. After owning it a day or two the SERVICE 4WD light comes on the message center. It goes away
after I turn the ignition off, but will come back after a while. It has come back two times now and I've only owned it a few days.
I read on another board that it could be a bad transfer case switch. Any other ideas?
Also, does anyone know if something like this would be covered under an extended warranty?
Thanks, BW
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"BW" wrote

a
away
Yes, what history code is stored in the ATC section? If it's 2725, then the problem is in t/case dash switch.
> Also, does anyone know if something like this would be covered under an

That will be hard to know unless you diagnose the problem properly and know what component needs to be replaced. Then you can call your warranty company and find out if "that" component is covered. A lot will depend on what kind of coverage you have.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the reply Ian. I don't know what the history code is, but I will find out.
BW

it
Any
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
<<< what history code is stored in the ATC section
I'm not a mechanic, but is there any way to obtain the error codes without special equipment?
Thanks, BW

it
Any
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
depending on the warrenty, but not really sure. also is there a used car warrenty where you live? here in N.C there is a minium one of 30 days or 1,000 miles. you may want to check into that.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks Charles,
The dealership has a 30-day warranty that will cover 15% parts and labor. I also bought a 1-year extended warranty although I don't really know what this covers. I'll probably find out in the next couple days. I won't be afraid to cancel the warranty if it doesn't work out in this case.
BW

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Not also that GM has a bulletin about the Shift Motor Encoder Sensor. I have replaced many. It also requires reprogramming.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Tech 117" wrote

have
I don't believe that bulletin applies to the Suburbans. I think it's specifically for the crow hopping that the AWD Bravada/Trailblazers experience.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No, It applies to specific transfer cases not vehicle models. As a GM Technician I do know this.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sorry, Is 2002 that has that bulletin.

I
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Tech 117" wrote

Yes, the specific transfer cases that happen to be in the Bravada, Trailblazer, Envoy vehicles. Have a look thru your SI2000 and see if you can find that bulletin for the 2001 Suburban that the OP was talking about. You won't find it, because the sensor replacement you are talking about doesn't apply to a 2001 Suburban. In addition to that, he was complaining about the "service 4X4" light coming on. The condition you refer to will not set a service light.
The GMT 360/370 models use either a 126 or 226 model t/case. The C/K 800 trucks (suburban) use either the 263 or 236/246 t-cases.....different beasts all together.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I believe the bulletin he is referring to is #03-04-21-001C .

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"GM Tech" wrote

Thanks, that's a good one. Still doesn't apply to the 2001 Suburban. That's the problem with TSB's. They are very model and year specific in most cases.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I believe the bulletin he is referring to is #03-04-21-001C . Cam

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Pull the dash switch and go over it very closely, I bet it will be the problem, I have seen too many with this problem. There is no need to replace the switch if you have any solder skills, I have done a few now and they take the greater part of fifteen minutes to remove and fix and reinstall.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had this happen to me about 3 weeks ago and it turned out to be the 4WD Selector Switch which was covered under my extended warranty. However, I have a $100 deductible and the bill came to $117 so....it cost me the $100.
Art

a
away
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
<<< However, I have a $100 deductible and the bill came to $117
Thanks Art,
That's my exact situation. I have a $100 extended warranty deductible as well. I'm getting it diagnosed tomorrow... we'll see if it's the selector switch. Based on everything I've read it seems like the likely culprit.
BW

it
Any
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Pull the switch and take the back cover off of it. it the circuit board is cracked, save some money and just get the switch and replace it yourself. Cam

has
an
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks Cam. I just may do that.
BW

owning
goes
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks to all who chimed in on this thread. I took the truck back to the dealership and it indeed turned out to be the transfer case switch (code 2725). Since I bought it used from the dealership a week ago they replaced it for free. Imagine my surprise!
BW

a
away
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Related Threads

    Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.