2002 Silverado 1500 Dash Lights Inop

I recently installed an alpine mp3/cd player in my 2002 Silverado 1500. Now the dash lights are inop. I'm not sure if the two are related, but the timing is suspicious. I tried plugging the original
stereo back in, and checked all the fuses but none of that helped. I also pulled the instrument cluster and checked the connections to make sure I hadn't bumped anything loose. When I installed the stereo I used a plug adapter and did not cut anything. I did connect the Alpine's "illumination" wire to its Chevy counterpart. When I turn the headlights on, you can see the digital odometer dim as it is supposed to, but still no dash lights. Is there a way to reset the computer to see if this is the problem? I was wondering if anyone has any ideas before I take it to the dealer for warranty repair. I'd hate to get blamed/charged for this...
Thanks in advance guys.
Oh Yeah, also my truck is non-Onstar, no power anything. Just a 6 cyl, 5-speed cheapie :)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check out the 10 amp illumination fuse on the right hand side of the dash... Bobo

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the tip, but I already checked that fuse (which is on the left side on my truck) as well as every other fuse on the entire truck.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.