2002 silverado 2500 trailering load button on shifter???

My on/off button on the shifter for pulling a trailer does not engage or the light doesn't come on. I didn't see a specific fuse for this option, am I
missing it? What other causes might there be for it not working or coming on?
Thanx in advance, Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yeah, yeah...... I know it is called the "Tow/Haul" switch, wither way it doesn't engage or come on.... any ideas?????

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mike wrote:

Did you check both sets of fuses?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
no, in fact I looked through the manual and didn't see anything specific for it, mind telling me where I might find them and what they are listed under?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mike wrote:

> no, in fact I looked through the manual and didn't > see anything specific for it, mind telling me where > I might find them and what they are listed under?
I don't know about the manual but there should be a set on the left end of the dashboard for which you can see the removable cover as you open the driver's door and another set under the hood in front of the driver with yet another removable cover. The backs of the covers each have a map on them naming the functions.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, I know where my fuses are but like I stated before I didn't see a "specific" fuse, anyone have any ideas?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check the rubber boot at the base of the column shifter. Chances are the boot is cracked and you can see inside. The wire for the switch is probably broken there. Mine is. It happens to most of them.
G

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.