2003 2500HD won't start...HELP

My Silverado, 6.0, 4sp auto tranny for some reason won't start. The only visible thing wrong is the shift indicator (all digital) goes straight to the "2" and
not park. It hasn't given any hints of trouble up till now and it has 20,000 plus miles. I know it's still a warranty issue, but I'd like to get it started to get it to the dealer. Any clues...anyone?????
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The starter won't engage while the truck is in gear, and for some reason (either electronic or mechanical), your truck thinks it's in 2nd gear.
If it's electronic in nature, try disconnecting the battery for several minutes and then see if that doesn't clear the problem.
If it's mechanical, try turning the key to the "run" position without starting it and running the gear selector up and down through the gears several times both quickly and slowly.
Hopefully, it's something as simple as a faulty neutral safety switch, which among other things tells the computer that the tranny is in gear or Neutral/Park. You could also try sliding under the truck to see if the wiring harness to the tranny is loose or damaged from debris.
Good luck - Jonathan
--
Jonathan A. Race
Lieutenant, EMS Supervisor
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Climb under the truck and have someone move the shifter from P thru 1 and so forth. Watch the shift linkage to make sure it's actually moving the switch on the left side of your transmission. Could be something as simple as a broken shift linkage.
Doc
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Just call the dealer. They'll come get it. H
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
That's exactly what I did.!!! I used the roadside assistance and all went perfect.!! Thanks to all who responded.!!!!!!!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.