2003 Blazer metal particles on oil drain plug

Bought this thing used a few months ago with about 18,000 miles on it. During my first oil change a week ago I noticed metal particles on the drain plug magnet. Took it to a local dealer and was told it wasn't bearing
material and that it might be left over from when the engine was cast. Sounds fishy to me. I wouldn't think casting debris would still be in there unless the oil was never changed or they never took the drain plug out if they did change it. Anybody had any experience with this before?
Thanks Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Your engine *IS* still wearing it's self in. BUT personally the only things I can think of that are ferrous & wear are the rings and I don't think they still should be. My best guess though, if it isn't jagged chunks your good.
~KJ~ My advice might be worth what you paid for it.

drain
there
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks. I'll keep an eye on it.
Mike

if
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Here's my experience, 2003 Silverado: My first oil change was at 3000 miles and it had small metal particles on the magnet. I filled it with Mobile 1 fully synthetic and my second oil change was at 9000 miles and there was no metal particles at all on the magnet. I'm not telling you what oil you should use, I just thought you might find this interesting.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.