2003 Tahoe heated seats keep coming on/off automatically...anyone else have this problem yet?

I originally posted this back in August 2003, no one had the problem. A trip to the dealer a short time later and they said they replaced the "heater module" or something, and a few months later it started
again. Now I'm faced with the fact/problem that it, as before, is intermittent, and Chevy says they cant do anything with it unless it is acting up when I take it for service (which of course it likely will not, it will work fine in front of them..SIGH.. so I figured I'd ask again before I make my umpteenth trip back to the dealer. (had other issues in addition to this)
Once again, the problem is:
Sometimes they (the heated seats) will come on as soon as I start the truck, but even if not it doesn't take long before they do. Sometimes they will rapidly cycle through the 3 temp settings over and over and over (low-med-high-low-med-high) etc.
If I turn them off, 30 seconds to a minute or so later they come back on,sometimes on high setting, sometimes on lower settings. Don't know if this is some kind of short or the computer system is going crazy or what...seems like I've had a few electrical problems with this truck.
I find it hard to believe with all the Tahoes on the road this has a unique problem that no one else has heard of, now a year later.
Thanks for any help.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Try this the next trip to the dealer..... Check for PI01850 March 2004
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks...I'll check into that
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.