454 chev motor home ( truck chassie)

have replaced botton, cap, plugs now runs dogg. fuel unburnt little or no pickup. Ran great before the repairs. ( dist was rusty )

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
was running great.... 36K miles - tune up.. replaced plugs, rotor botton and cap. now runs but still a dog.. was great 6 months ago.. smells of unburnt fuel... changing the above- would it change the timing ? should I also change plug wires?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

What year is engine? ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How often do you drive the mobil house? Old gas could be the problem. If you don't drive it at least once a week gas can get nasty. I put Stabil in my 55 Chevy and the wife's motorcycle -Lawn Mower and such. I had a problem with the 55 three carbs nasty inside-electric fuel pump-blew two starters off-the carbs float stuck and I had to change oil three times ten quarts each time. I put stabil in and no problems since. 55 has 454 mark 4 in it. Good Luck -------Wayne
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.