4WD NOISE

Hello, i have a problem with my 99 z71. It has recently began making a strange noise. it is similar to the noise it would make if you forgot to take it out of 4wd and drove on the highway at a high rate of speed but the 4wd is
not engaged has anyone else had this problem and how did you fix it. thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hello, i have a problem with my 99 z71. It has recently began making a strange noise. it is similar to the noise it would make if you forgot to take it out of 4wd and drove on the highway at a high rate of speed but the 4wd is not engaged has anyone else had this problem and how did you fix it. thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bad wheel "hubs" (loose wheel) makes that EXACT noise.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
if your have locking hubs try unlocking them and if they are your hubs are bad
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Z71 FAN wrote:

Mine is doing the same thing. I am told it is either the auto select switch set on the dash, or the module at the transfer case is bad.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
does your service engine light come on. I'm going to take it to a mechanic to get it fixed but would like to have some idea before I take it. thanks Brenda EdCrabb wrote:

--
Message posted via http://www.carkb.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.