77 GMC k20 4x4 - 305 engine

My truck starts great and idles around 700-800 rpm, once you start driving and then go into neutral or park it will rev up to 1000 rpm. So when I am in DRIVE, and want to goto reverse - i go into neutral
and it revs so high the CLUNK is louder than i would like it before it gets to reverse.
In drive and reverse it idles around 700-800 rpm.
any ideas?
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Feb 5, 5:41 am, snipped-for-privacy@gmail.com wrote:

Quite possible your choke is sticking on, remove the top of the air cleaner and see if the butterfly is not completely open. If it is partially closed, it may be due to a stove, or electric choke coil that has failed. Or possibly a pull-off is not functioning due to no vacuum signal or a ruptured diaphragm. Is it an original carb i.e. Quadrajet? Check and see if your idle stop screw is resting on the stop when the idle is high, if it is then you could possibly have an internal fuel leak that is causing a higher speed, this will typically have some rich condition symptoms. Your carb could just be out of adjustment, your timing could also be advanced too far.
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Its a new Edelbrock Carb, but I did not install it - the previous owner did. So there might be some adjustments he did not do.
I will check if the butterfly is not completely open.
Add pictures here
✖
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.