'88 'Burban Update...

New TBI base gasket installed, rusted shut EGR port opened, and the previous tune up...
Idle is down to about normal. When I just start to open the throttle as in
throttle plates JUST start opening, she stumbles bad! TPS?
If I give her the gas and roll off the throttle, she idles a little high(estimated 8-900revs), if I tap the throttle and let her snap closed, Idles right down and is relatively smooth. Any ideas?
EVERYONE has been AWESOME helping me with this! I want to thank EVERYONE!!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
BTW...Still cranks more than normal before she starts...
| New TBI base gasket installed, rusted shut EGR port opened, and the previous tune up... | | Idle is down to about normal. When I just start to open the throttle as in throttle plates JUST start | opening, she stumbles bad! TPS? | | If I give her the gas and roll off the throttle, she idles a little high(estimated 8-900revs), if I tap the | throttle and let her snap closed, Idles right down and is relatively smooth. Any ideas? | | EVERYONE has been AWESOME helping me with this! I want to thank EVERYONE!!! | |
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

previous tune up...

in throttle plates JUST start

high(estimated 8-900revs), if I tap the

smooth. Any ideas?

EVERYONE!!!
Did you clean the throttle body real good while it was off? Carbon build up can cause the throttle body butterfly to stick open. And you say that if you let it snap shut it idles OK. Could be the problem. Also if it's stuck open it may be causing a hard start.
Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The Throttle body is clean. Its almost like the throttle plates have to be COMPLETELY closed to keep too much air out. I think I am gonna replace the IAC valve. Couldn't hurt at least, right?
| > New TBI base gasket installed, rusted shut EGR port opened, and the | previous tune up... | > | > Idle is down to about normal. When I just start to open the throttle as | in throttle plates JUST start | > opening, she stumbles bad! TPS? | > | > If I give her the gas and roll off the throttle, she idles a little | high(estimated 8-900revs), if I tap the | > throttle and let her snap closed, Idles right down and is relatively | smooth. Any ideas? | > | > EVERYONE has been AWESOME helping me with this! I want to thank | EVERYONE!!! | > | > | | Did you clean the throttle body real good while it was off? Carbon build up | can cause the throttle body butterfly to stick open. And you say that if you | let it snap shut it idles OK. Could be the problem. Also if it's stuck open | it may be causing a hard start. | | Brian | |
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Defiantly can't hurt, and they aren't that expensive. I had one bad on my 1994 Z34 with the 3.4 liter and it would idle high all of the time, it wasn't inconsistent like yours. But different engine could have different over all symptoms. Check your manual there's a setting for the pintle in the valve. At least there is for the 3.4 liter motor.
Brian

throttle as

up
you
open
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.