89 Blazer Full Size cranks, but won't start

89 Full Size Blazer, TBI 5.7L On first atempt when cold, acts like it wants to start, but then stalls. Every attempt after that all it does is turn over and over but never fires.
-Plenty of gas, fuses are fine, battery @ 14.4v -Replaced the plugs and wires because they were worn out anyway, but that didn't help. -Removed Cap and Rotor. Heavy corrosion, replaced both. Still no start. -Tested the coil with an ohmmeter, turns out it was bad, replaced it, still won't start. -Tested the plug wires with a spark tester and I see a spark. -Tested fuel pump, you can hear it turn on for 10 secs at ignition. -Fuel injectors spraying heavy into throttle body at ignition, doesn't seem to have a problem with pressure. Strong fuel odor comes from under hood after attempting to start. -Checked EGR valve. It was stuck. Replaced it. Still no start. -Testing ECM via SES light. It displays code 12 indicating system is operational. No other codes flash. -Tested power and ground to ESC, TPS, MAP Sensor, & Coolant sensor. All fine. -Checked Ignition module. Appeared to be in bad shape. Replaced it. Still no start. Well, I have exhausted all my and the GM shop manuals resources and are here to ask or additional help. Any ideas would be greatly appreciated. Thanks...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Geez...I am tired after reading what you have went thru so far. Stupid question, with the disto cap off, is the rotor turning?? Is rotor pointing to #1 SP @ tdc??

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.