90 K1500 brake light problem

Let me repost this since I didn't get any answers. Feel sure someone on here has had this problem before!
I have a 90 model K1500 chevy 4X4. The dash light that lights up when the
parking brake is applied keeps flashing on and off. It is at regular intervals, just like a turn signal when it is on, and at about that speed. Both brake lights are working and all other dash lights are working properly.
Anyone have any ideas?
Charles
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

What other diagnostics have you done? Is the break mastercylinder full? What's the owners manual say about that light flashing? Are there any obvious leaks at the wheel cylinders? When was the last time you had the brake fluid flushed, or system bled? Need more info. Could be a lot of things.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Master cylinder is full. Owners manual doesn't say anything about it, other than what it is for. It still works right when I apply the parking brake, just goes to flashing instead of going out when I let the parking brake off.
Recently replaced front brake rotors and pads, but had this problem before that. System was bled at that time, but not what you would say flushed. Master cylinder is full. Rear brakes were replaced about a year ago. It has good brakes, with good pedal height, just the light keeps flashing.
Thanks Charles>
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

There's a black plastic box with two connectors on it attached to the bracket that the master cylinder attachs to. This is the RWAL control module. Try unplugging the connectors for about 30 sec(key off). If your light goes out, there's a problem with the RWAL. Drive it around until the light comes back on and then take it to the dealer and have them scan it for codes. -- Old Crow "Yol Bolsun!" '82 FLTC-P "Miss Pearl" '74 XLH chopper(gone but not forgotten) BS#133, SENS, TOMKAT, MAMBM
--
Posted via a free Usenet account from http://www.teranews.com


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.