91 S-10 4X4.... brake indicator light is flashing Moore Code

About a months ago the brake dash light suddenly decided to stay one Unpluged feeds from the parking brake switch and the brake pressure switch..... no effect on the light
Then last week it started flashing out 6 dots and a dash, or a dash and 6 dots, continuously when running. I don't have ABS
Are those aliens trying to signal me.....again?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

RWAL Fault codes Codes for Dodge RWAL, Ford RABS and GM RWAL applications are similar but have a few differences:
1.. Should not occur (replace the controller if it does) 2.. Open isolation valve circuit or defective ABS module 3.. Open dump valve circuit or defective ABS module 4.. Grounded or closed RABS or RWAL valve switch 5.. Excessive actuations of dump valve during ABS braking 6.. Erratic speed sensor signal 7.. Shorted isolation valve or defective ABS module 8.. Shorter dump valve or defective ABS module 9.. High resistance or open speed sensor circuit (resistance should be 1000 to 2500 ohms) 10.. Low speed sensor resistance (Dodge & Ford only) 11.. Open speed sensor circuit (GM only) 12.. Stop lamp switch circuit (Dodge & Ford) 13.. ABS module speed processor (Dodge & Ford only) 14.. ABS module program (Dodge & Ford only) 15.. ABS module RAM memory failure (Dodge & Ford) To manually clear a stored fault code on GM and some Dodge trucks with RWAL, remove the ABS fuse or disconnect the battery for 5 seconds. Ford RABS codes will automatically clear when the ignition is turned to the off position.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ken wrote:

6 flashes - Speed Sensor Fault. Probably dirty contacts or wiring is chafed someplace. Notice any problems with the speedometer or the cruise control?
--
Steve W.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Speedo is fine, while I've never used the cruise control feature. I'll try it later today.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.