92 chev rough idle at start

My 92 chev 1500 5.7 has a rough idle at start for about 10-20 sec then it kicks back up to normal idle runs fine till shut off then does same thing over again. i have replaced EGR and IAC. Any suggestions would be greatly
appreciated thanks Nick
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
See if one of the injectors leaks down after shutoff.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
kaster wrote:

    Does your "Check Engine" or "Service Engine Soon" light come on? How many miles are on the truck? Charles
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
yes check engine light does come on once the idle kicks back to normal the light comes on. i was told that a oxygen sensor may cause this make any sense? i know what isnt the cause but tired of trial and error to figure it out its getting spendy. also noticed that sometimes it will want to die when i go to stop but not always just occasionally.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What is the code???

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
kaster wrote:

    Have someone use a scantool on it. A proper diagnostic of the problem can cost less then tossing parts at it. Charles
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.