92 K1500 Shakes, shudders on 4WD engagement ???????

1992 k1500 5.7 4L60 4WD
Got snow yesterday and engaged 4WD at low speed under 15 mph and when 4WD is engaged truck shakes and has mucho vibration. This happens as
soon as the floor lever is pulled back to 4 Hi, happens when moving in Drive or with transmission in nuetral.
Any Ideas???? With snow coming this truck is going to be useless without the 4wd.
Thanks in advance.
J
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
astermech wrote:

If I understand what you wrote your saying it vibrates when in 4x4 and in motion. And that you shifted into neutral while in motion and it still vibrates?
If so check the U Joints on the front drive shaft and check the front output yoke on the transfer case for play. A bad (dry or worn) U Joint will cause vibration. Also look at the front axles for damaged boots or CV joint problems. Even though they turn all the time while the vehicle is moving it may be that one is worn enough to cause a problem when it is under power.
--
Steve W.
Near Cooperstown, New York
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No noise per say but a terrible shudder, I will try to look into further tomorrow.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.