92 S10 Blazer suspension problem???

That last few days the steering on my S10 has gotten lose.
It's hard to explain, but when driving down the highway, the truck sways side to side. Like the wheels are being steered back and forth slightly.
When the front goes an inch or so to the right, theback is going left. Every once in a while I can feel a slight nudge or pulling in the wheel. Like what you feel when driving over a lane change and you go over the crack in the road.
I had the upper and lower ball joints, idler arm, pan arm bar and all stabilizer bar joints replaced a year ago. All of that looks good under the truck. Nothing looks loose or wrong.
The tires have 92K on them and are low on tread. The fronts have a little less then 1/4 inch left and the rears slightly less then that. Would the low tread cause it to start to feel like that?
Now that I feel it a lot, I think it's been doing it fro quite some time just not as bad. Always thought it was a side wind or something.
Any ideas?
Lannie
PS Truck as 287K on it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
92 S10 Blazer suspension problem??? Group: alt.autos.4x4.chevy-trucks Date: Sat, Dec 13, 2003, 12:03am (CST+6) From: snipped-for-privacy@email.net (LS) That last few days the steering on my S10 has gotten lose. It's hard to explain, but when driving down the highway, the truck sways side to side. Like the wheels are being steered back and forth slightly. When the front goes an inch or so to the right, theback is going left. Every once in a while I can feel a slight nudge or pulling in the wheel. Like what you feel when driving over a lane change and you go over the crack in the road. I had the upper and lower ball joints, idler arm, pan arm bar and all stabilizer bar joints replaced a year ago. All of that looks good under the truck. Nothing looks loose or wrong. The tires have 92K on them and are low on tread. The fronts have a little less then 1/4 inch left and the rears slightly less then that. Would the low tread cause it to start to feel like that? Now that I feel it a lot, I think it's been doing it fro quite some time just not as bad. Always thought it was a side wind or something. Any ideas? Lannie PS Truck as 287K on it.
Looks may be decieveing......You cant look at a frontend to see if its loose you need to raise it... Most shops will check a frontend for free....Or check it yourself you nee to raise the whole frontend up at one time....try to wiggle the tire side to side with out turning it if the tire has alot of play something is loose or worn out..Also check your tire pressure...Also when you had everything replaced did you have a alignment done on it also? Steve C
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
They did do an alignment but with the tires being almost worn out can that affect the alignment or ride that much? It feels like when you have a TON of weight in the back of a truck and the front steering feels lose and wiggly. If that's the right description.
Lannie
(LS)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
(Top Post)
Your tires being worn out may have ripped radials in them......Which Ive seen make a wiggle...And feel like the frontend is wanting to dance..Also will cause what they call radial pull...But what it sounds like is something may be loose.....To see if its your tires just rotate them and if the problem goes away then know its your tires but if not have it inspected.... Steve C Re: 92 S10 Blazer suspension problem??? Group: alt.autos.4x4.chevy-trucks Date: Sat, Dec 13, 2003, 1:57pm (CST+6) From: snipped-for-privacy@email.net (LS) They did do an alignment but with the tires being almost worn out can that affect the alignment or ride that much? It feels like when you have a TON of weight in the back of a truck and the front steering feels lose and wiggly. If that's the right description. Lannie
(LS) That last few days the steering on my S10 has gotten lose. It's hard to explain, but when driving down the highway, the truck sways side to side. Like the wheels are being steered back and forth slightly. When the front goes an inch or so to the right, theback is going left. Every once in a while I can feel a slight nudge or pulling in the wheel. Like what you feel when driving over a lane change and you go over the crack in the road. I had the upper and lower ball joints, idler arm, pan arm bar and all stabilizer bar joints replaced a year ago. All of that looks good under the truck. Nothing looks loose or wrong. The tires have 92K on them and are low on tread. The fronts have a little less then 1/4 inch left and the rears slightly less then that. Would the low tread cause it to start to feel like that? Now that I feel it a lot, I think it's been doing it fro quite some time just not as bad. Always thought it was a side wind or something. Any ideas? Lannie PS Truck as 287K on it. Looks may be decieveing......You cant look at a frontend to see if its loose you need to raise it... Most shops will check a frontend for free....Or check it yourself you nee to raise the whole frontend up at one time....try to wiggle the tire side to side with out turning it if the tire has alot of play something is loose or worn out..Also check your tire pressure...Also when you had everything replaced did you have a alignment done on it also? Steve C
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
(LS)

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the help "Doc" and Steve.
I will rotate tomorrow. I jacked up each side and grabbed each tire on the left and right side and tried to turn the wheel back and forth. They moved 1/4 to 1/2 inch. That seems excessive doesn't it? None of the tire rod ends look lose but like you said it could be deceiving.
My local shop will give me a free estimate and inspection since they did all the original work. Just have to wait till I have time to get it in.
Thanks!
Lannie
(LS)

sways
slightly.
wheel.
under
time
tire
something
had
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.