93 GMC Jimmy starter problems

4.3l Vortec, 4Dr, 4WD 155K miles. two months ago, after driving for more than an hour or so and parking the vehicle, my starter motor wouldn't turn
over, until after about 30 minutes of sitting. no crank, no click, just plain ol' nuthin'. I've read in a few other groups that this was a possible overheat problem in the solenoid, so i replaced the starter with a duralast gold model starter (non-refurb) from autozone, and the problem was gone...or so it seemed as this week the probelm has resurfaced. the mechanic I took it to said he checked everything else and the starter motor had to be the problem. just wondering what the experts here might know about this. This is the 2nd starter motor I've gotten from them this year (OE model solenoid died in Jan), and they've already agreed to ship a third to replace this one, but I'm just wondering if perhaps I need to select a different brand/supplier.
thanks in advance,
JV
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
See if you can fab up, or buy, a heat shield to protect the starter and its components from the manifold heat. I suspect you'll have similar results from other brand starters...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Are there any problems with interlocks (clutch/Neut/Park/Brake)?
JV wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.