93 Suburban trip meter

My odometer works but the trip meter does not. Replaced instrumentation cluster for other reasons, trip meter still does not work but the odometer does. Any suggestion as to what the problem could be?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The speedo is electronic on a 93. Never had to repair one but it is likely that there is two signals from ECM to it. one for speedo and one for odometer. You might check wiring and ECM. (computer module) ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, I have referred to the wiring diagrams but cannot find a seperate circuit, so it must run with the odometer.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ken,
I have the same problem on my 93 c1500 cheyenne. Its been that way for years.
Isn't that amazing? I bet we are not the only ones.
I've got the cluster with the tach...but I'd guess the trip mechanism is the same.
Skimmer

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have found this very frustrating, especial since there does not appear to be any accurate information on correcting the problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I have GM dealer manual going back to 98 that "should" cover it but I do not know if 93 and 98 uses same design. ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks SnoMan
I believe the mechanisms are the same but the visual design is differenet. Thanks anyhow.
Ken
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

There is a big writeup on trouble shooting it but it also mentions OBD2 codes for it which your vehicle does not support. ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.