94 Blazer Poor Running

Help please. I have a 94 Blazer VIN "W". Problems started when it shut down on the road. No stumble, or miss, it just shut down. When we turned
the key to on the pump did not run. Towed it home and changed the fuel pump. It now runs (the pump) when the key is turned to on. The old punp was fried, terminals were burned from arcing and one wire was completely separated from pump. It will still not start. Cranks and cranks, but does not start. At first we sprayed a little gas into the intake with no difference. No codes were stored. Checked all the fuses, all were good. Checked the spark. It seemed a little weak, but there was spark. Replaced the computer since it seemed like the injector was not firing. No joy. Tried the squirty gas thing again, and it started. Finally figured out that if you kept the throttle open wide, it would run on its own, but would not idle at all. RPMs would not exceed 2000. Fuel pressure is 60+. A little black smoke from the tail pipe. Is there another fuse panel other than the one under the Steering Wheel.
KenG
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

60+ psi at the schrader valve. check to make sure your return line is not kinked or plugged. that would be my first guess then maybe but doubtfully the fp regulator. Alot of times your fuel return line will get kinked or twisted when you are putting things back together.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
David Johnson wrote:

Check the fuel pressure regulator, see if there is pooled fuel, I would also check the above. Isn't 60 psi alittle high for a '94
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.