'94 Suburban Turn Signal

My turn signals stopped working in the last few days. The flashers still function properly, but when I try to use a turn signal nothing happens. Since flashers are working I am thinking this is likely a problem with the
switch in the steering column.
First question is whether this logic seems correct. Second question is how hard is it to replace.
Thanks in advance,
Kirk
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Its your turn signal flasher. The hazards work with a different flasher. It should be plugged into your fuse box.

how
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
OK, I replaced the flasher, but still no go. Back to the original thoughts?
Thanks Again,
Kirk

still
the
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Kirk Grau wrote:

You are "sure" that you replaced the "correct" flasher?
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, I went back to basics yesterday in the light of day and found a fuse that had blown. Replaced the fuse and went for a drive only to have it blow after a while. Now I am looking for a dead short somewhere. Any help trying to trouble shoot this and narrow down the possibilities would be appreciated.
Thanks,
Kirk

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.