95 Blazer rough idle

My 95 Blazer has been idling rough since I took it on a hunting trip in South Dakota (1500 miles in 5 days). I cleaned the EGR valve with sea foam and that did not help. The check engine light comes on every so
often and I did get it to read a cylinder three miss fire. I replaced the wires and plugs. Check engine light went out but still runs rough. I decided to replace the fuel injector spider assembly since it was original equipment (142K). The engine is new last year and has about 20K. I was thinking of replacing the EGR but there is not engine light (yet) and they are expensive. I already have about $350 in it and am in need of some help. Any suggestions.
Regards, Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Temperature sender may be bad.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the lead! I will have to see if i can find info in the temp sendor. Any idea where this is located. Is it on the intake manifold near the thermostate?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes, sender is on intake manifold. Don't confuse it with the one that is in the head.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Did you replace the fuel lines inside the plenum when you replaced the injector? Cylinder 3 is on the correct side to have a leaking line cause a misfire. The kit you need is called a "Nut Kit".
On Mon, 20 Dec 2004 10:23:59 -0500, "Mark the shade tree guy"

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Nut Kit" p/n is : 17112705
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes i did replace the intake fuel line or the nut kit. It looked like the fuel line was leaking at the back of the air plenium where it connects to the fuel lines. I did check the gas milage and it seems like i am getting an extra two miles per gallon! The thing just runs rough after it warms up.
Thanks for your reply.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.