95 K1500 z-71 starter problem

Just put a new battery on due to the AC/Delco battery positive side mount came out of the battery and now the starter won't engage.......I can hear the solenoid clicking when I try to crank but the starter won't turn
over.........all other lights and electrics work fine....have double checked all battery connections and everything is tight and clean there.........my guess is the starter has gone south but double checking here first............was cranking and running fine yesterday until last night when the positive side terminal came out of the battery....................Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

checked
Seems like too much of a coincidence that the starter died in unison with the side mount of your battery. I'd check the voltage of your new battery. Also, cables sometimes corrode under the insulation and moving them around enough to change the battery, might have done them in.
Dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Found the problem, the starter went bad also...........first I have ever had a starter and battery go at the same time......but I have never had a GM starter last for 200,560 miles either!!!!..........replaced the starter and the battery cable and the battery......cable was corroded some, so while I had starter off replaced it too........funny thing was that in the past when a starter would start to fail you would know it by it dragging or sounding different. This one never did, it just failed.........thanks for your response.........Mark

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Mark & Sharla Thompson wrote:

    Usually for a side post terminal to break free of the battery case, something has to be putting tention on it. Especially if it is laying outside the case.
    Check the cable going all the way from the battery to the stater. Make sure the soliniod post is tight (will not twist), and that soliniod is not cracked on the post end. Charles
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
did the terminal MELT out? if so see if your starter is frozen up
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.