95 S-10 blazer wont go into 4wd

I had a hard time getting the truck into 4wd on a hunting trip last month. 4wh and 4wl lights just flashed. Now it doesn't respond at all. During the trip mentioned earlier I was in 4wh a lot. It was very
muddy. The last time I was successful getting it into 4wd I had to put it in reverse.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I don't know if this is helpful or not but many of the 95s had a recall for the 4WD actuator/solenoid (I think that's what it was called). My experience was that mine was done for free at the dealer on my 95 SLT when I had no problems whatsoever. I then, later, was stuck in a rocky bog and ended up with the same symptoms you have. The cure was replacing the torn hose to the actuator/solenoid. When you press the dash switch, can you hear the solenoid? If so, my guess would be the air line being damaged / if not, I would side with a dead or failing actuator/solenoid. I hope this helps. Thanks! Andrew.
in article snipped-for-privacy@n67g2000cwd.googlegroups.com, snipped-for-privacy@hotmail.com at snipped-for-privacy@hotmail.com wrote on 12/13/06 10:05 PM:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.