95 Stumbles and Misses

Hello,
89,000 miles, 4.3 Vortec
My Silverado has been stalling and missing over the past few weeks. I have put new plugs/wires (twice, the plugs were burnt up both times),
distributor/rotor (just a few days ago), a fuel filter, and adjusted the timing, yet the problem persists. What else can it be?
Thanks, Jimmy
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
possible coil failure...too much spark ?.. Check your charging system to make sure your not over charging..

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You might do a fuel pressure check (about 14 PSI from pump and about 9.5 to 10 PSI from regulator) and check TPS and maybe MAPas well. Might check for some water in fuel too. ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
would that cause the plugs to burn up ?
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Lean mixtures or preignition (spark knock) ----------------- TheSnoMan.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
any check/service engine soon lite on? These engines were famous for egr issues amungst other things. Let us know if a lite was or is on- then have it scanned. This may be the clue we're(you're) looking for. Good luck snipped-for-privacy@peru-motors.com

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.