'96 chevy p/u kept running after key turned off - whats wrong??

I had to disconnect battery to shut it down, now it won't start ???

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Is there an after market remote starter installed in the vehicle that could be acting up, or something wrong with ignition switch.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Now that's truly odd... even with the battery unhooked, it should keep running.
Check your fuse for the ECM (Marked as such)... and have a look at the fuel pump/Fuel injector fuses as well.... But I have no idea what up with that... first I've heard of it.
HDS
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Can't say what kept it running - but pulling the battery off of any vehicle with a "CS" type alternator (used on most GM's since about 86-88) while the engine is running will almost always fry the alternator. The alt counts on there being a load across it's output.
When you were turning off the key, were the dash lights and things going out? If not - I'm starting to think it's just a shorted ignition switch!

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.