97 C1500 5.0 Hard start cold?

My Grandfather has a 97 C1500 with a 5.0. I think it's a Vortec engine. It's always been hard to start cold, so I did a full tune up and ran great when warm, but you just couldn't get nice throttle response when you gas it
in Park. Now, the truck is almost impossible to start cold. Sounds like it close to firing, but no cigar...Check engine light is on, but I don't have a scanner. Does this sound like a throttle position sensor? TIA
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
============ 97 C1500 5.0 Hard start cold? Group: alt.autos.4x4.chevy-trucks Date: Sun, Aug 1, 2004, 7:41am (CDT+1) From: snipped-for-privacy@worldnet.att.net (thebigfellow)
My Grandfather has a 97 C1500 with a 5.0. I think it's a Vortec engine.
It's always been hard to start cold, so I did a full tune up and ran great when warm, but you just couldn't get nice throttle response when you gas it in Park.
Now, the truck is almost impossible to start cold.
Sounds like it close to firing, but no cigar...
Check engine light is on, but I don't have a scanner.
Does this sound like a throttle position sensor? TIA
================== No, it does not.
yer welcome, post script MarshMonster ~:~ ================
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like the ECT sensor may be faulty.
thebigfellow wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.