97 Sonoma Transfer Case Noise?

Hoping someone here can help me out. About a mile into my drive home Friday I noticed a "rattling" noise. First thought it was exhaust related but when
I got underneath Saturday the only loose part I found was a skid plate. Tightened that up thinking all was good. No luck. Today the noise continued. It's not engine related, nor is anything rubbing, dragging, etc. While nursing it home today I was trying different driving tricks to pin-point the noise. It starts above 25-30 mph, and stops when speed drops below 25-30. When I shifted (manual shift transfer case) into 4-HI, the noise went away. I went back to 2-HI; no noise for about a mile or two, then it returned. Go back to 4-HI, no noise. Back to 2-HI, there it is again.
I plan to check the fluid level and shift linkage tomorrow, as it seems a little tough going into 4-HI now. Any other suggestions for things to check, common problem, etc.? Also, my vacuum actuator is dead, so the front right never engages. Given this, is it safe to drive in 4-HI (to prevent whatever is causing noise) at highway speeds (~30 miles of 70 mph interstate) without risking tire/gear bind?
Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.