98 Jimmy auto switch to 4 hi

Hello, Read some other post with similar problems, but not the same deal..
This problem started this winter, during a snow storm and driving the Jimmy,
auto switched to 4 hi, did not see it change just noticed the light when I stopped at a light. Clicked 2 hi and it stayed.
This past weekend with heavy rains in NY I was driving on parkway and it did it 2x's again. It stayed in 2 hi for the rest of my drive home.
The recent work done was for an oil leaks and have had several trips over the past 8 months as new leaks appear.
If memory serves me correctly this is what has been done. Replaced hoses 2 different types I believe remote and radiator. Replaced the remote holder.
The leaks have gotten better. I know he has "washed down" the engine to check it do not know what chemicals he has used but it was foul smell for the ride home.
I still have a small drip but when I bring in it 2 weeks for the LOF I'll have him check the leaks again.
Is there anything I can get him to start to check, the problem is obvious.. it is so intermittent.
Thanks, Dave-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I had the exact same problem on my sons 97 Jimmy last summer. Driving down the road it would switch to 4 high on its own. After a lot of trouble shooting I took someone's advice here (or was it in the alt.trucks.chevy ?) I disconnected the battery for about an hour to reset the shifting computer (that's not the name of it but it escapes me at this moment). Have not had any trouble since then. Its worth a try. GM
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.