98 Z71 auto transmission slamming into second gear????

I've had this truck going on 5 years, and every 6 months or so, I'll put it into drive and take off and the truck slams into second gear? I'll stop at a sign and take off again, and it will keep doing it..Then it will stop
and not do it again for months? Should I be freaking out? It will do it at a very slow speed also.. It just "jerks" into second gear.... Any thoughts?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
probably 4l60E. electronic shift. have scanned for error codes. check and regrease electronic connection on passenger side of tranny. Use grease designed for electric connections.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 97 Z71 did the same thing at 55000 miles the dealership had to replace the valve body in transmission.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
We have a '97 Z71 and the day we bought it back in 1999 it did this and we took it back to the dealership and they fixed it, so yes i would go to the dealer to get it fixed before it causes more problems. Transmission is getting ready to go.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.