"99 Fuel Gauge

1999 Silverado, Z71, 5.3, Stepside, 101,400 miles. Problem with fuel gauge after filling tank. Occasionally the fuel gauge will go to "E" and "Low Fuel" warning light will come on. Shifting to
"neutral" and rev RPM's OR turning off the ignition and back on, will correct the problem. After the first 50 miles or so, every thing works ok till the next fill up. Any suggestions from the experts as a start point, Gauge or Tank unit ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have same problem with 2000 Silverado Ext cab 4.8 except it happens nearly every time I start it but returns to normal once the truck starts moving. I would also like to know where to start looking to solve this problem.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Charles Roberts wrote:

Tank unit.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Having a rroblem with fuel gauge all the time. The fuel gauge usually stays on "E" and "Low Fuel" warning light stays on. There are times after filling the gauge will register 1/4 or as high as 3/4 full. Out of the blue the gauge works but never register the correct fuel. Took it to the dealer many times but they stated no problem, now out of warrant they want 1000.00 to fix the problem but can't tell me the problem Any suggestions from the experts as a start point, Gauge or Tank unit ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.