99 GMC Yukon / Chev Tahoe H02S sensors

I have a 1999 GMC Yukon that is setting DTC P0140 and DTC P0160 indicating a lack of activity on the O2 sensors located after the catalytic converters.
When I look under the truck (to try and go through the diag procedures) I found that both sensors are installed but look like they have NEVER been connected. I can only find the wires from the sensors hanging there and there doesn't seem to be any plugs from the wiring harness for them to connect to... I have owned the truck since 99 and it has never been an issue, ie the MIL didn't used to light up. I had the truck through the Drive Clean emission testing last year and it passed fine. It is due for another emission test now but the stupid MIL keeps coming on for the above DTC's. It makes no sense to me that these O2 sensors are not connected and there is nowhere to connect them to? Has anyone else experienced this? The service manual indicates that they 'should' be connected via plug C1 to the EMC. Anyone with ANY ideas ? I am in Ontario, Canada, any help would be appreciated
Thanks Paul
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I've seen a few instances where the harness got loaded with snow and pulled down where it got wrapped up in the front drive shaft.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No, these are the O2 sensors located beside / almost behind the transmission / transaxle housing, there just doesn't seem to be any harness connection for them. It almost looks like someone had cut the wires from the sensors at some point. My OTC diag tool still indicates a HO2S B1 S2 (B2 s2) heater voltage of 0.450V constant. I didn't know if GM had abandoned these sensors? I really don't know where to go from here.
Thanks
Paul
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

And from there the harness usually runs forward to the PCM which is in the left front corner of the engine compartment. Or, isn't this thing 4X4?

Yup, that's what they look like when they get yanked off.

Yup, that's what they look like when they get yanked off... Try to picture what might happen if your neck tie got caught in a moving fan belt...

Heater voltage is 12 volts, the .450 is the O2 circuit bias voltage, if it stays at .450 constantly, it among other things could mean that the O2 sensor circuit is open.

Not if the truck is OBD2 compliant. It will say on the underhood tune up (VECI) label whether it is or not.

Probably your best bet is to find a similar vehicle, slide underneath it and take a look at where the harnesses are routed. The harness from the passenger side adjacent to the post-cat O2 sensors loops over the transfer case and then runs forward along side the transmission, from there it routes upward into the main PCM harness. Again, if any snow collected on the harness, there is a good chance that it got pulled down and entangled in the front axle drive shaft or some other rotating piece of the machinery. odds of this happening are increased if the transmission was out for service and the mechanic did NOT replace the harness back into position in its retaining clips.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No, its 4x4 and yes the harness does run up to the PCM (left side engine bay looking from sitting in the drivers seat) All other connections are there (connectors for transaxle / transmission) but there aren't any loose connections that would mate up with the O2 sensor wires. Also both S2 sensors have been disconnected, I could understand if 1 of them got caught on something and yanked off ... but both? while all othere connections under there are OK? seems a bit odd
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.