99 silverado hesitation

Hello group,
I'm in need of some ideas, my truck is as follows: 1999 silverado, 4.3 vortec V-6, 5 speed manual trans, 100000 miles.
I get a hesitation when I apply small amounts of throttle, If I push the
pedal down, more like half to three quarters then the hesitation goes away and the truck accelerates. Worst case is when I have a short stop, say I run into a store for smokes and a soda, (5-10) mins, the hesitation is very severe to the point that it will not rev over 2000 RPM, UNLESS I push the pedal past half throttle it feels almost like its loading up on fuel and opening the throttle clears it and it starts to accelerate normally again. Twice now when this has happened it has backfired through the exhaust, although not a very harsh backfire, but loud enough that I heard it, again thats only happened 2 times. The real kicker? This doesn't happen all the time, most of the time but not all, once in a while it runs smooth as silk.
What I've done:
R&R dist cap rotor wires plugs< 2 times, fuel filter, air filter, TPS, multiple cans of injector cleaner. also had to replace one O2 sensor (B1S2) other O2's are working fine according to scan tool.
Fuel pressure seems to be ok as after it clears and under high acceleration it runs fine. I'm considering the injectors and spider unit as a possible next step, but thats a $350 dollar part, I can install it.
So if anyone has any ideas, tips, hints, please don't "hesitate" to reply :)
Thanks to all that take the time to read this ...
--
In a world without wall or fences ... who need windows or gates??
-unknown-
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I have a 1994 Chevy S-10 blazer and hubby just changed the spider in it. It would not idle and didn't run very well. Also, you might want to check the egr valve, as after we changed the spider, somehow we got a piece of carbon in it, and would run ok going down the road but just had a surge kinda, after cleaning the egr valve, (just replaced it 2 years ago) it runs fine now. That's just our experience with 4.3 vortec. Carol

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
dnysis wrote:

Thanks Carol
I'll check the EGR tomorrow morning. But its lookin more like the spider .. Did the hubby think it was a tough job? It looks pretty easy from the manual.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
In alt.trucks.chevy, EMG had the audacity to say that:

Sticky throttle? Throttle potentiometer?
*R* *H*
--
Tim and I a hunting went
We found three damsels in a tent,
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
i had a 99 S-10 with the 4.3 V-6 and i had a slight miss when the engine was running and was shifting weird.(automatic trans). i sprayed the throttle body down with throttle body and injection spray and it solved my problem. don't use regular carb cleaner to spray the throttle body because it will take the coating off the throttle plate and damage it. buy some stp throttle body spray in a blue can and try that. also what kinda gas you putting in it. the cheap gas made my truck run like crap. i stuck with the 89 at mobil, bp, and shell only. i won't do the no name stations. plus when i change the oil i started using lucas oil stabilizer when i changed oil in the truck. my truck used 5 quarts of oil and all you do is use 4 quarts of oil and 1 quart of lucas oil stabilizer and that brought my oil pressure back up. it's about 7 dollars a quart but it's worth it. try all that and see how your truck runs.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
TROY BUONO wrote:

Thanks Troy,
I also only use better grades of gas ... usually sunoco 89 I also tried shell 89 ... there was no difference. I'll grab some of that stp cleaner tomorrow and give that a try ... I just passed 100k and usually use castrol 5-30 and every other change I use the lucas. I should be comming up on another oil change real soon. Thanks for the reply and I'll let ya know how I make out.
--
In a world without wall or fences ... who need windows or gates??
-unknown-
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.