Blazer Rear Washer

Greetings, I bought my son a used 97 Chevy Blazer. When we use the rear washer, the fluid drips out under the rear of the vehicle and none squirts on the
glass. Any suggestions on what to look for to try and fix this would be appreciated.
George Evans
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
-------- Original Message --------

lift-glass/drop-gate. I had to take the panel off the tail-gate reconnect a fluid hose that had become disconnected. Using the washer just sprayed fluid inside the tail-gate which then leaked out the bottom.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 98 with lift gate and operable glass was disconnected up by the right hinge for lift gate. Had to remove ceiling trim panels along the rear to reconnect hose and re-position hose so it would stay connected.
George Evans wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
were do you fill the rear washer on a 99 jimmy? mine I can hear humming, but no liquid comes out, the front is full.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It's likely the same bottle as the front. Look for 2 pumps on the bottle in the engine bay. If it's the same bottle, you need to find the place where it's disconnected. Follow the thread, the others have made suggestions for common places for the line to be disconnected...
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.