Blazer Rear Window Washer

2001 Blazer LT. While driving home in a pretty good snowstorm the other night, the rear washer apparently goes kaput. Plenty of washer fluid in the reservoir (front washers work ok), and I can hear the
pump motor "working" when I push the button on the dash, but no fluid to the rear window.
Anyone want to make a diagnosis and suggest the fix?
Thanks!
Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Phil McCracken wrote:

Common one is a plugged rear nozzle, next common problem is the line breaking at the junction inside the headliner (on vehicles with the large rear hatch) or under the rear floor mat on the tailgate equipped ones. My usual first step is to put a chunk of air hose over the nozzle and apply 5-10 pounds of air and see if I can get bubbles in the reservoir. If yes then it was probably blocked. If no you listen/feel for the leak. The lines coming apart makes a MESS under the carpet or inside the headliner.
--
Steve W.
Near Cooperstown, New York
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check a pinched hose were the snap that holes the hose to the wiper arm is.. Happened to me that was all it was.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.