Brake light problem 92 Jimmy

Hi all I am new to this group. I have a 92 S Jimmy with a weird brake light problem. When using the left turn signal the dash lights flash with the signal but when using the right turn signal everything stays normal. If I
press the brake pedal with the parking lights off the front parking lights come on with the brake lights. If the parking lights are on the taillights are brighter than normal like the brake lights are on but if I push the brake pedal the lights do get a little brighter. With the parking lights on and the brake pedal pushed the left turn signal does not flash but the right one works like it should. Sorry about the long post but it is a weird problem and thought I would state all the stuff the truck does. Thanks David
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
your Brake light and parking light wires are shorted together .
I saw this problem once before .. it turned out that one of the rear bulbs had shorted filiments in it. Changed the bulb and all worked fine ! Also Does ur truck have a TRAILER HITCH PLUG ?? if so CHECK it also Two wire shorting together BRAKE/Parking. you can narrow it down BY Turning on the SIGNAL LIGHT with the KEY OFF
since everything works normal in Turn signal RIGHT HAND position, Your problem is in the Wiring /bulb on the LEFT REAR
Acura God wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the reply! I will check the bulbs first. The truck does not have a trailer harness so that eliminates that. It seems that all this started after I used the hazards one night. Will check it out and let you know what I find. Thanks again, David

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Acura God wrote:

Hopefully The Switch in the Steering colum Didnot go out !!
Will check it out and let you know what

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It was a bad taillamp bulb. The two circuits had melted together. Thanks

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.