brake pedal too hard

my chevy s-10 blazer(4.3 ltr.) brakes just got real hard to push, with very little power. I looked into replacing vacuum hose and check valve, but it comes up as "not necessary" or N/A. Is it probably the booster???

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Probably. All vacuum bossters have a hose and check valve, just because it says N/A doesn't mean it's not there. Quick check: With the motor off, pump the brakes a few times and then hold the pedal down nice and firm. Start the truck with the pedal still held. It should move down towards the floor a bit and soften up when the motor turns over. If it doesn't, likely the booster.
Doc
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"" wrote: > my chevy s-10 blazer(4.3 ltr.) brakes just got real hard to > push, with very > little power. I looked into replacing vacuum hose and check > valve, but it > comes up as "not necessary" or N/A. Is it probably the > booster???
Check the vacuum to the booster,if you have vacuum then replace booster
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.