chevy starters grinding

i have 2 chevys with the same starter problem an 85 suburban and 79 scottsdale both 350 v8 we put new starters in and they would sound fine for a few starts and then
it would grind horribly even broke a starter we tried shimming in the scottsdale but didnt work i have a 9\16 wrench that i adjust the starter in the subrban until it sounds fine starter is not holding in place i dont know why or how to fix it
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like you have some Bad BENDIX or the housing bushings are worn
needhelpalot wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sometimes shimming the starter makes it worse because the mountiong plate too thick to begin with.........try grinding down the mounting pad a little at a time. Also you must support the front half of the starter using the factory bracket that bolts to the block. Or you are installing the wrong starter for your flywheel, or maybe the ring gear on the flexplate is shot-out, or maybe the flexplate is cracked completely around the crank flange. or maybe you should have another beer.
--
Mad-Dog
'79 Chevy K-10
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.